Excel: Estrarre il mese da una data

Immagine
Excel: Estrarre il mese da una data
Argomento

Problema

Abbiamo una colonna che contiene delle date. In un'altra colonna vogliamo estrarre il mese per poter: ordinare l'elenco per mese, fare una tabella pivot, ecc.

Estrarre il mese da una data

Soluzione 1

Il primo modo è utilizzare la funzione MESE().

Inseriamo nella cella B2 la funzione =MESE(A2).

Excel funzione mese

Il risultato è il mese in formato numerico

Excel funzoine MESE

Soluzione 2

Il secondo modo è utilizzare la funzione TESTO().

Inseriamo nella cella C2 la funzione =TESTO(A2;"mmmm").

Il significato del secondo argomento è:

  • "m" visualizza 7 (cifre senza eventuale 0 iniziale)
  • "mm" visualizza 07
  • "mmm" visualizza lug
  • "mmmm" visualizza luglio

Excel funzione TESTO

con la 4 opzione il risultato è il seguente

Excel funzione TESTO

A questo punto possiamo possiamo effettuare tutte le operazioni che vogliamo sui mesi